THE VEPR FORUM

Atterete Dominatum
It is currently Mon Aug 21, 2017 8:20 am

All times are UTC




Post new topic Reply to topic  [ 8 posts ] 
Author Message
PostPosted: Tue May 09, 2017 6:21 pm 
Offline

Joined: Thu Mar 23, 2017 3:57 pm
Posts: 35
I'm about to lose my mind with these things. I know there was going to be a "bit" of fitting, but the sheer time and amount of metal I've pulled off to still not have a usable magazine is unbelievable.

I've shaved the rear angled part of the magazine first as it could not seat all the way.

After it seated it would not fully engage the safety so I had to file up on the under side of the lug and now I can get them to seat and click in.

Then there is a secondary issue that developed. when I jam the mag in, it will NOT drop free, I can hit the mag release and its not even coming into contact with metal. After a ton of reading I found a thread talking about how the newer(newest?) batch were too thick and was causing binding front to back. so I shaved down the face(?) of the lug spine (no idea what the appropriate terms are, sorry) as per the image that CSS posted. Well, I've gotten most of the issues solved so I took them to the range to see how they perform, and this is where I am stuck now.

I used slugs (sighting in new optic) and for one mag, it will drop from the magwell after each shot. The other magazine will hold for a few but eventually come free from the gun on its own. Secondly, even with the material removed the magazine is so tight in the well that when I fully seat the mag with any force it gets wedged and has to either be shot or have the mag jostled to "drop" down onto the magazine catch.

I know these magazines are supposed to be the end all be all mags for the V12, but I haven't had to do anything to my two SGM mags, and they work flawlessly, while these I still can't trust. Any help is appreciated.


Top
 Profile  
 
PostPosted: Wed May 10, 2017 4:12 am 
Offline

Joined: Tue May 10, 2016 2:28 am
Posts: 111
You need to tell CSSpec he will take care of you.


Top
 Profile  
 
PostPosted: Wed May 10, 2017 12:04 pm 
Offline

Joined: Thu Mar 23, 2017 3:57 pm
Posts: 35
yeah, that'll be my last resort. I like to fix things myself if at all possible so I can learn in the process, but if I can't get it dialed in with some assistance here I'll contact them directly and see what can be done.


Top
 Profile  
 
PostPosted: Wed May 10, 2017 3:42 pm 
Offline
Business Member

Joined: Mon Oct 22, 2012 7:14 pm
Posts: 268
This video may help.. It is supposed to display on the product page but it seems to disappear when viewed on most mobile devices.

https://www.youtube.com/watch?v=13Sslg4Cg_Q


Top
 Profile  
 
PostPosted: Wed May 10, 2017 8:55 pm 
Offline
User avatar

Joined: Thu Oct 13, 2016 3:02 pm
Posts: 71
Location: Mckeesport, PA: AKA the slag pile (the only place where the garbage man delivers)
hey bro i hear your problem sorry you are having issues with getting an aftermarket mag to function reliably, this does happen since they are aftermarket and there are fitment issues sometimes, best thing i can tell you is send it back and ask for a replacement be sent out. other than that i can only recommend from personal experience use only oem 5, 8 and 10 round factory molot mags and you should b perfectly fine, just my 2 cents.

_________________
https://www.youtube.com/user/cpu68


Top
 Profile  
 
PostPosted: Wed May 10, 2017 10:24 pm 
Offline

Joined: Thu Mar 23, 2017 3:57 pm
Posts: 35
I've seen the video before. I reprofiled the under ledge of the rear locking lug and just hit the rear spine harder. It fits in better now, guess time will tell if the mag self-ejects under fire or not.

SKS - yeah, I'm probably going to grab a few more molot mags. I like them the best of all 3 anyhow, just hate the price. I'll buy if I ever see a sale.


Top
 Profile  
 
PostPosted: Sat May 13, 2017 12:53 pm 
Offline

Joined: Sun Jul 06, 2014 1:35 am
Posts: 2
Legionusa.com on sale


Top
 Profile  
 
PostPosted: Fri May 19, 2017 11:28 am 
Offline

Joined: Tue May 10, 2016 2:28 am
Posts: 111
One of mine started self ejecting when fired. I'm guessing I didn't have any issues before because my muzzle brake and longer barrel were reducing the recoil.

Now that I'm at 14" the recoil must be too stiff.

I'll have to see if more material needs removed (or if I butchered it and removed too much)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group