THE VEPR FORUM

Atterete Dominatum
It is currently Tue Dec 18, 2018 9:19 pm

All times are UTC




Post new topic Reply to topic  [ 3 posts ] 
Author Message
PostPosted: Sat Sep 26, 2015 11:33 pm 
Offline

Joined: Sat Jul 27, 2013 5:56 pm
Posts: 42
Greetings all!

I got one of the unicorn Veprs a couple years ago - firewood stock, but square receiver and adjustable gas block.

I has 3 adjustable settings - the gas block has a hole that is covered by a sleeve that has 2 different size holes and a 3rd spot that is totally closed off. I've read quite a few people say that the rifle is overgassed, so I started off with mine on the #2 setting - the smallest opening. I had no problem with the standard spam can surplus.

I got a surplus spam can of 182gr match ammo. First time I took it out, using the factory 5rnd magazines, first round went fine, second (maybe third) got a fail-to-feed. It wedged the bolt on the round and actually bent the bullets (Pics to follow...).

I cleared that, tried again, same thing.

I adjusted the gas setting to 3, which is the totally closed setting. Still had the same issue.

After that, I just used the rifle in single shot mode - individually load one round into the chamber.

I'm going out to sight in my new POSP scope tomorrow, and I'd like to use the (theoretically) more accurate ammo to do so.

Any thoughts?

Thanks all!


Top
 Profile  
 
PostPosted: Sun Sep 27, 2015 4:13 am 
Offline
User avatar

Joined: Tue May 13, 2014 4:02 am
Posts: 542
Well, it seems you didn't try the #1 setting... I would try that too. It may need the bigger gas port for the heavy ball.

Also, go back to the ammo you had success with to make sure nothing "new" happened with the mag or system at the same time you switched to the heavy ball ammo.

_________________
"Must get Moose and Squirrel!"


Top
 Profile  
 
PostPosted: Sun Sep 27, 2015 6:35 am 
Offline
User avatar

Joined: Mon Feb 25, 2013 7:31 pm
Posts: 78
Location: Средний Запад
First thing I would advise is that you properly clean and lube the bolt carrier and gas piston assembly.
Not sure what's up with the funky coloring going on inside your gas block.

The problem does suggest that your not getting enough pressure into the gas system so going to setting 1 would allow the least amount of gas to the piston.
But try what was suggested by trying what worked before and for Shits and Giggles try setting 1 (I don't think it will help though).

What else do you know about the ammo?....does it have less of a charge because it's match grade or made for bolt actions like Mosin's.

Just throwin that out there... I don't claim to know anything about ammo... just thinkin.

I've been running mine on setting 1 since I got it using 147 grain up to 203 but nothing in the match grade arena.

_________________
.....Image
Жизнь похожа на коробку людей ... Вы никогда не знаете, когда вам придется ........ эээ ... использовать свое воображение.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 3 posts ] 

All times are UTC


Who is online

Users browsing this forum: No registered users and 8 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group